1

Topic: Please help - "MIDI Learn" invaded my pianoteq

My Pianoteq desktop suddenly fires "MIDI Learn - move the midi controller that you want to assign" at ANY interaction with the desktop (e.g. A/B switch, instrument selection etc.), no idea why this started. Of course I can still operate the menu at least to select instruments but that takes too much time when playing live.
I have a PC tablet so no keyboard shortcuts either.
Does anyone know how to get rid of "MIDI Learn"? Is it Pianoteq or is the error coming from my keyboard?
I have not upgraded to Pianoteq 6,no time to install and test it before the gig today, but I will upgrade soon.

Thank you for any hint :-)

2

Re: Please help - "MIDI Learn" invaded my pianoteq

Can you tell us what OS you are using, what interface between the keyboard (and what type of keyboard)? All that will help people to try and remotely diagnose/remedy your problem.

3

Re: Please help - "MIDI Learn" invaded my pianoteq

Have you opened the Pianoteq Options window and under MIDI Options, selected "Minimalistic" for Global MIDI Mapping?  Otherwise, you do need a clean keyboard unlike mine —and without sticky keys!

But, you may just want to see if a relaunch helps.

Incidentally on Pianoteq 6, after you command click within a MacOS, or, maybe Windows click within a Windows environment, merely to do the MIDI Learn, in addition to the MIDI Learn popup message which comes up centered on the interface, at the lower right corner next to the condition slider, the message phrased "MIDI mappings (unsaved)" will appear —but only upon the fully completed MIDI Learn. You remove it once you save your edit to MIDI mappings, switch to an alternate MIDI mapping preset, or relaunch.

Last edited by Amen Ptah Ra (27-09-2017 10:05)