1

Topic: Pianoteq and Airplay

Hi, I'm trying to understand why, when I have my audio output on my MacBook Pro set to airplay to my Apple TV, the audio gets routed to my laptop speakers instead of via airplay to the Apple TV?

All other apps on my Mac have the audio routed to airplay, but not Pianoteq.

Note that I'm not using this for live playback during actual piano playing.  But I would like to use this when playing recent or other MIDI files in Pianoteq when I'm reviewing them.

I've searched the forum, and the Pianoteq manual, and the online information, but so far have not found an answer.  Is it not possible?

Thank you.
Linda

2

Re: Pianoteq and Airplay

I don't have a Mac so this is just a rough guess from using the Linux version.

Pianoteq by default prefers to connect to the underlying sound audio device to avoid latency and this would bypass the AirPlay driver.

Post a screenshot of the Devices tab on the Audio/MIDI setup option.  You may be able to choose a higher-level Mac sound driver where it goes through the all software layers (at the cost of latency).

3

Re: Pianoteq and Airplay

Well, strangely enough, I seem to have gotten it to work.  In the Pianoteq options, the Apple TV does not show up as a potential output (only built-in output and "none" are listed).  For any other output, I have to first select the output using the audio icon pull-down on the Mac menu bar.  When I select the Apple TV from the menu bar, it then shows up as the selected output in Pianoteq, though it still wasn't working, as I mentioned.

But, once I've selected the Apple TV from the menu bar, and it shows up as selected output in Pianoteq options, the sequence to get it to actually work is:

- In Pianoteq options, choose the built-in output (I then tested this with the test button)
- Then, in Pianoteq options, choose the Apple TV output again, and test with the test button

At this point, when I play back from a MIDI file in Pianoteq, the audio does get routed to the Apple TV.

I don't know why there is a problem with the normal selection of audio output (seems like a bug), but I have a workaround now.